使用 pip 安装特定的软件包版本

我正在尝试使用通过--no-site-packages选项创建的新 virtualenv 安装 MySQL_python 适配器的 1.2.2 版本。 PyPi 中显示的当前版本是1.2.3 。有没有办法安装旧版本?我发现有一篇文章指出应该这样做:

pip install MySQL_python==1.2.2

但是,安装后,它仍在站点包中显示MySQL_python-1.2.3-py2.6.egg-info 。这是此软件包专用的问题,还是我做错了什么?

答案

TL; DR:

  • pip install -Iv (即pip install -Iv MySQL_python==1.2.2

首先,我发现您要执行的操作有两个问题。由于已经安装了版本,因此应该卸载当前现有的驱动程序或使用pip install -I MySQL_python==1.2.2

但是,您很快就会发现这不起作用。如果查看 pip 的安装日志,或者进行pip install -Iv MySQL_python==1.2.2您会发现 PyPI URL 链接不适用于 MySQL_python v1.2.2。您可以在这里验证: http : //pypi.python.org/pypi/MySQL-python/1.2.2

由于 sourceforge.net 的最新升级和 PyPI 的过时 URL,下载链接 404s 和后备 URL 链接正在无限重定向。

因此,要正确安装驱动程序,可以按照以下步骤操作:

pip uninstall MySQL_python
pip install -Iv http://sourceforge.net/projects/mysql-python/files/mysql-python/1.2.2/MySQL-python-1.2.2.tar.gz/download

您甚至可以通过pip install命令使用版本范围。像这样:

pip install 'stevedore>=1.3.0,<1.4.0'

并且如果该软件包已经安装并且您想要降级,请添加--force-reinstall如下所示:

pip install 'stevedore>=1.3.0,<1.4.0' --force-reinstall

一种方法,在提出这个职位 ,是提版本pip为:

pip install -Iv MySQL_python==1.2.2

即使用==并提及版本号以仅安装该版本。 -I, --ignore-installed忽略已安装的软件包。

要安装特定的 python 软件包版本,无论是第一次,升级还是降级,请使用:

pip install --force-reinstall MySQL_python==1.2.4

MySQL_python 版本 1.2.2 不可用,因此我使用了其他版本。要从索引查看所有可用的软件包版本,请排除该版本:

pip install MySQL_python==

我相信,如果您已经安装了软件包,则 pip 不会用其他版本覆盖它。使用-I忽略以前的版本。

有时,先前安装的版本会被缓存。

~$ pip install pillow==5.2.0

它返回以下内容:
已满足要求:/home/ubuntu/anaconda3/lib/python3.6/site-packages(5.2.0)中的 pillow == 5.2.0

我们可以将 --no-cache-dir 与 - I 一起使用来覆盖它

~$ pip install --no-cache-dir -I pillow==5.2.0

由于这似乎是 pip 版本 10 中引入的重大更改,因此我降级为兼容版本:

pip install 'pip<10'

此命令告诉 pip 安装低于版本 10 的模块版本。在virutalenv 中执行此操作,这样就不会增加 Python 的站点安装速度。

我最近在使用pip-I标志时遇到了一个问题,我想在某处进行记录:

-I在继续之前, -I 不会卸载现有软件包;它将仅安装在旧版本的顶部。这意味着应将两个版本之间应删除的所有文件保留在原处。如果这些文件与其他已安装模块共享名称,则可能导致奇怪的行为。

例如,假设有一个名为package 。在package的一个文件中,它们使用import datetime 。现在,在package@2.0.0 ,它指向标准库datetime模块,但是在package@3.0.0 ,他们添加了本地datetime.py来替代标准库版本(无论出于何种原因)。

现在可以说我运行pip install package==3.0.0 ,但是后来意识到我实际上想要的版本是2.0.0 。如果现在运行pip install -I package==2.0.0则不会删除旧的datetime.py文件,因此任何import datetime调用都会导入错误的模块。

就我而言,这表现为奇怪的语法错误,因为该软件包的较新版本添加了仅与 Python 3 兼容的文件,并且当我将软件包版本降级以支持 Python 2 时,我继续导入仅 Python-3 模块。

基于此,我认为在更新已安装的软件包版本时,总是比使用-I卸载旧软件包总是更好。

下面的命令对我有用

Python 版本 - 2.7

包 - python-jenkins

命令 - $ pip install 'python-jenkins>=1.1.1'

您可以通过两种方式安装任何版本的软件包: -A)。 pip install -Iv 软件包名称 == 版本 B)。 pip install -v 软件包名称 == 版本

为一个

在这里,如果您在安装时使用 - I 选项(当您不知道软件包是否已安装时)(例如'pip install -Iv pyreadline == 2. * 或类似的东西),则您将安装新的单独的程序包,而相同的现有程序包具有不同的版本。

对于 B

  1. 首先,您可能要检查是否有违反要求的情况。 点子检查

2. 然后查看点子列表已经安装了什么

3. 如果软件包列表中包含您要安装的特定版本的软件包,那么更好的选择是先通过pip uninstall package-name 卸载该版本的软件包。

4. 现在,您可以继续通过pip install -v package-name == version重新安装具有特定版本的相同软件包,例如 pip install -v pyreadline == 2. *